July 21, 2018

Archives for August 2012

Altiris Job for Pixologic ZBrush 4 R4

We got a ticket we quite a few requests to install the latest version of ZBrush 4 R4 on several PC’s.

I went ahead and started looking on Pixologic’s site and on the web. I could not locate any info doing a silent install. I tried extracting the .exe with no luck.
You can also run the installer and then check under the AppData\Local\ to see if it extracted an msi or setup files. I didn’t find anything useful.

I tried running the exe with different switches from the command prompt.

ZBrush_4R4_Installer_WIN.exe /s
ZBrush_4R4_Installer_WIN.exe /q
ZBrush_4R4_Installer_WIN.exe /h

None of the above worked.

I got lucky with –help

ZBrush_4R4_Installer_WIN.exe --help

It brought up a pop up with these commands.

ZBrush 4R4 4R4
Usage:

--help Display the list of valid options

--version Display product information

--unattendedmodeui Unattended Mode UI
Default: none
Allowed: none minimal minimalWithDialogs

--optionfile Installation option file
Default:

--debuglevel Debug information level of verbosity
Default: 2
Allowed: 0 1 2 3 4

--mode Installation mode
Default: win32
Allowed: win32 unattended

--debugtrace Debug filename
Default:

--enable-components Comma-separated list of components
Default: application,documentations,plugins,3dpe,BlendShapes,decimationmaster,imageplane,
multimapexporter,paintstop,subtoolmaster,transposemaster,uvmaster,zapplink,adjustdfzsizeplug
Allowed: documentations plugins 3dpe BlendShapes decimationmaster imageplane multimapexporter
paintstop subtoolmaster transposemaster uvmaster zapplink adjustdfzsizeplug

--disable-components Comma-separated list of components
Default:
Allowed: documentations plugins 3dpe BlendShapes decimationmaster imageplane multimapexporter
paintstop subtoolmaster transposemaster uvmaster zapplink adjustdfzsizeplug

--installer-language Language selection
Default: en
Allowed: en ar bg ca da nl et fr fi de el es es_AR he hr hu it ja ko pl pt_BR pt ro ru no sl sk sq sv tr zh_TW zh_CN va cy cs

--prefix Installation Directory
Default: ***unknown variable default_installdir***

So I tried

ZBrush_4R4_Installer_WIN.exe --mode unattended

from a command prompt and I did get one pop up from “Microsoft Visual C++ 2010 x64 Redistributable Setup” when i clicked on Ok the installation finished.

I then went into the Altiris Deployment Console for 6.9 to create the software job.

I called the job Zbrush 4R4 then clicked on Add | Distribute Software then clicked on the folder to browse to the location of ZBrush.
Then under Additional command-line switches section I entered

--mode unattended

then clicked on finish.

I ran the job on a few test PC’s and it installed fine and that Microsoft pop up does not come up.
You still have to manually Activate the software.

Altiris Jobs

Where I work they have Altiris 6.9 and are in the process of getting Altiris 7.1 up and running in parallel.

I thought I would share some of the software jobs I got working. So others don’t have to re-invent the wheel.

I will try and post one a week. If you have any request let me know.